Email sending can be delayed
Incident Report for Locaboo GmbH
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 11:17 CEST
Monitoring
Our email service provider postmarkapp is currently reporting problems and delays in sending emails.
Posted Jul 29, 2022 - 10:11 CEST
This incident affected: E-Mail Service.